Export Resolution

Discussions that concern the community rather than the makehuman software

Export Resolution

Postby eddy99 » Thu Sep 30, 2021 10:04 am

I am exporting figures in DAE format into blender but I seem to be losing quite a bit of detail on clothes.
Am I doing something wrong or is it the default resolution of Makehuman?

Thanks Eddy
eddy99
 
Posts: 6
Joined: Wed Feb 19, 2020 9:42 am

Re: Export Resolution

Postby joepal » Thu Sep 30, 2021 12:14 pm

There should be the same number of vertices in the export as in makehuman. Maybe it looks like less resolution due to how the model is rendered in the target application? You'll normally have things such as smooth and subdivision enabled, or whatever they're called in the target application.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 4130
Joined: Wed Jun 04, 2008 11:20 am

Re: Export Resolution

Postby eddy99 » Thu Sep 30, 2021 1:32 pm

I can't see anywhere in makehuman to increase the vertices. I have tried the smooth tab but it did not make much difference.
Once imported into blender the detail is already lost any subdividing make no difference.
eddy99
 
Posts: 6
Joined: Wed Feb 19, 2020 9:42 am

Re: Export Resolution

Postby joepal » Thu Sep 30, 2021 1:41 pm

First, going via DAE if your end goal is blender is an unnecessarily cumbersome detour. Recommended workflows for blender is going via MPFB for imports, or in worst case MHX.

This said, you shouldn't lose any vertices between MH and blender even if you go via DAE.

Can you post screenshots demonstrating what you see?
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 4130
Joined: Wed Jun 04, 2008 11:20 am

Re: Export Resolution

Postby eddy99 » Thu Sep 30, 2021 2:02 pm

screen.png


grab_2021-09-30_14.54.38.png
eddy99
 
Posts: 6
Joined: Wed Feb 19, 2020 9:42 am

Re: Export Resolution

Postby joepal » Sat Oct 02, 2021 11:30 am

This isn't a question of resolution. The details in the MakeHuman view isn't due to having more vertices. It's due to having a normal map. The problem you have in blender is that you don't see the normal map in the view port.

Viewport:

with_normal_map.png


Simply switching to eevee mode:

with_normal_map1.png


I guess it is possible that you might have lost the normal map in conversion via DAE.

In that case you can add it back by setting up a normal map chain in the material:

normal_map_chain.png
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 4130
Joined: Wed Jun 04, 2008 11:20 am


Return to Community discussions

Who is online

Users browsing this forum: No registered users and 1 guest