Page 1 of 1

Grainy Renders

PostPosted: Sun Sep 10, 2017 1:11 pm
by Taholmes160
i folks

I am rung into a bit of a problem. my renders are turning out really grainy fr some reason. im using cycles render

Im not even sure what other info you need to help diagnose


Re: Grainy Renders

PostPosted: Sun Sep 10, 2017 1:27 pm
by blindsaypatten
In Cycles the less light that hits a surface the more grainy it will be, whether due to low lighting or shadows, or indirect lighting, etc. Increasing the number of samples will reduce graininess, as will brighter lighting, depending on the scene. There is a new filter that denoises renders in the latest versions of Blender (2.79?). This is a Blender thing not a MakeHuman thing. Sorry to be terse, I have to run.

Re: Grainy Renders

PostPosted: Sun Sep 10, 2017 9:04 pm
by wolgade
Another cause for noise: Small light sources. If there's no artistic reason for small lamps than try to make them bigger. You might be interested in this article:

Re: Grainy Renders

PostPosted: Mon Sep 11, 2017 11:29 am
by joepal
Another tip, apart from the ones in wolgade's link, is to use ambient occlusion instead of drastically increasing the power of the existing light sources.

I usually run with:

* Clamp direct: 0
* Clamp indirect: 10
* Filter glossy: 0.2
* Ambient occlusion factor: 0.5
* Ambient occlusion distance: 5

The new denoising feature in 2.79 is nifty but sometimes produces artifacts in very detailed scenes (such as when you have a detailed bump map for graininess on rock etc). When/if I use denoising, which I usually don't for the final render, I turn down the power of it and run with:

* Radius: 4
* Strength: 0.25
* Feature strength: 0.25
* Enable relative filter

Re: Grainy Renders

PostPosted: Tue Sep 12, 2017 12:23 pm
by Taholmes160
Thanks for the help guys:

I changed up my lights from lit tubes in floroescent light, to flat panels and it seems to have helped, I'll keep working on it -- hope to have a few pics to post in the days or weeks to come