MakeClothes2 --- What's this about?

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

MakeClothes2 --- What's this about?

Postby SaltyCowdawg » Thu Aug 27, 2020 4:08 pm

It's been almost a year since I last used MakeClothes2 so this could be some form of PEBKAC issue.

Mashed the button, clothes not made and go the following in Blender.

Code: Select all
Traceback (most recent call last):
  File "/home/peter/.config/blender/2.83/scripts/addons/makeclothes/operators/createclothes.py", line 103, in execute
    mc = MakeClothes(clothesObj, humanObj, exportName=name, exportRoot=rootDir, license=license, author=author, description=desc, context=context)
  File "/home/peter/.config/blender/2.83/scripts/addons/makeclothes/core_makeclothes_functionality.py", line 155, in __init__
    if MAKESKIN_VERSION >= LEAST_REQUIRED_MAKESKIN_VERSION:
TypeError: '>=' not supported between instances of 'tuple' and 'int'

location: <unknown location>:-1




Any thoughts?
Peter L. Berghold <peter@berghold.net> or <Salty.Cowdawg@gmail.com>
Retired IT with 30+ years in the business
User avatar
SaltyCowdawg
 
Posts: 435
Joined: Fri Aug 09, 2013 3:12 pm
Location: Ayden NC

Re: MakeClothes2 --- What's this about?

Postby punkduck » Thu Aug 27, 2020 9:42 pm

SaltyCowdawg wrote:It's been almost a year since I last used MakeClothes2 so this could be some form of PEBKAC issue.

Mashed the button, clothes not made and go the following in Blender.

Any thoughts?



arrgh .. :oops:

makeskin has a version number of 3 components (0, 9, 0) ... and LEAST_REQUIRED_VERSION in utils is an integer => results in a python hiccup

I will change that (or Joel).

Since you work with Linux you can get a positive result earlier, so quick (and in a way stupid) workaround until then: in the file where the program complains change:

if MAKESKIN_VERSION >= LEAST_REQUIRED_MAKESKIN_VERSION:

in

if 2 > 1:

(which is always true). Otherwise that tool won't work until it is fixed (maybe tomorrow evening, not yet it is midnight over here ) ...

We will bundle these tools, I guess ...
User avatar
punkduck
 
Posts: 956
Joined: Mon Oct 17, 2016 7:24 pm
Location: Nuremberg, Germany

Re: MakeClothes2 --- What's this about?

Postby SaltyCowdawg » Fri Aug 28, 2020 12:41 pm

punkduck wrote:
if 2 > 1:

(which is always true)



Somewhere in the world I am sure is a math geek who has found a math proof that says otherwise! :-D

I will make the change... a hacking I will go...
Peter L. Berghold <peter@berghold.net> or <Salty.Cowdawg@gmail.com>
Retired IT with 30+ years in the business
User avatar
SaltyCowdawg
 
Posts: 435
Joined: Fri Aug 09, 2013 3:12 pm
Location: Ayden NC

Re: MakeClothes2 --- What's this about?

Postby punkduck » Fri Aug 28, 2020 1:22 pm

Yupp Elv mentioned, that you had a problem. Well it is good that you found that.

Joel improved the presentation of the version numbers in MakeSkin and I changed the same for MakeClothes, so the number is shown in menu (to answer questions later etc.).
Internally Makeclothes asks for a valid version to include MakeSkin .. and crashed. I just did a hotfix directly in the master of MakeClothes. So github is already okay. At least on my box it runs now.

Funny:

Yesterday I really was too tired, just wanted to give an answer and didn't remember that ">=" also works for complete arrays in python correctly (I am a perl and C guy mostly) :roll:

LEAST_REQUIRED_MAKESKIN_VERSION = (0,9,0) in utils.py would have been the better hack ;)
User avatar
punkduck
 
Posts: 956
Joined: Mon Oct 17, 2016 7:24 pm
Location: Nuremberg, Germany


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: No registered users and 1 guest