Makehuman 1.2.0 Cannot Open Models Created with Previous Ver

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Re: Makehuman 1.2.0 Cannot Open Models Created with Previous

Postby CHEED » Thu Sep 17, 2020 9:32 am

Aranuvir wrote:
Maybe the path simply points to the old folder

But it will still parse that folder, and in case it contains mhm files, they will be shown. And if I get the original post correctly it's not a problem of finding the files, but getting them to load. Anyway, we will have to wait for answers of the OP, anything else is simple guess work...


Yes - that is the problem. Loading the files.
Deliberate Creator | Life By Design; Not Default
User avatar
CHEED
 
Posts: 55
Joined: Thu Aug 25, 2011 6:53 am

Re: Makehuman 1.2.0 Cannot Open Models Created with Previous

Postby CHEED » Thu Sep 17, 2020 9:40 am

RobBaer wrote:OT

If I remember correctly, and settings is the problem here, you can just delete "settings.ini" and MH will generate a proper default "settings.ini" version for you.


I deleted and still doesnt load.

Here is my warning message:

showing task Logs
hiding task General
Exception during event onFileSelected
Traceback (most recent call last):
File "./core/events3d.py", line 211, in callEvent
method(event)
File "./apps/gui/guiload.py", line 113, in onFileSelected
gui3d.app.loadHumanMHM(filename)
File "./core/mhmain.py", line 405, in loadHumanMHM
self.selectedHuman.load(filename, True)
File "./apps/human.py", line 1538, in load
if not _compare_versions(version, getShortVersion(noSub=True)):
File "./apps/human.py", line 1454, in _compare_versions
return match1.groups(1) == match2.groups(1) and match1.groups(2) == match2.groups(2)
AttributeError: 'NoneType' object has no attribute 'groups'
Deliberate Creator | Life By Design; Not Default
User avatar
CHEED
 
Posts: 55
Joined: Thu Aug 25, 2011 6:53 am

Re: Makehuman 1.2.0 Cannot Open Models Created with Previous

Postby Aranuvir » Thu Sep 17, 2020 10:29 pm

Ok that's rather old stuff. The problem is the version string. Apart from the fact that MakeHuman should not produce this kind of error in case of an incompatible version string, which I consider a minor bug, you can try a quick workaround by setting the version string to 1.0.0. I didn't check it myself, if it will load in that case and you should be prepared your model might look quite different, because things have changed a lot since then.
Aranuvir
 
Posts: 1222
Joined: Sun Oct 12, 2014 2:12 pm

Re: Makehuman 1.2.0 Cannot Open Models Created with Previous

Postby CHEED » Fri Sep 18, 2020 6:52 am

Aranuvir wrote:Ok that's rather old stuff. The problem is the version string. Apart from the fact that MakeHuman should not produce this kind of error in case of an incompatible version string, which I consider a minor bug, you can try a quick workaround by setting the version string to 1.0.0. I didn't check it myself, if it will load in that case and you should be prepared your model might look quite different, because things have changed a lot since then.


Okay - will give it a try. Otherwise, I will have to re-create the models/characters if all fails.
Deliberate Creator | Life By Design; Not Default
User avatar
CHEED
 
Posts: 55
Joined: Thu Aug 25, 2011 6:53 am

Previous

Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: Google [Bot] and 1 guest