Can't enable MH Community Plug-in in Blender

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Can't enable MH Community Plug-in in Blender

Postby MTKnife » Fri May 10, 2019 2:57 am

I just upgraded to Blender 3.79 last night, and downloaded the latest version of the MH Community Plug-in, and whenever I try to enable it in Blender, I get an error, specifically line 85 of the init file ("register register_class(cls)", which throws a ValueError with a message indicating that the class in question is already registered as a sub-class.
MTKnife
 
Posts: 252
Joined: Tue Sep 01, 2015 5:22 am

Re: Can't enable MH Community Plug-in in Blender

Postby joepal » Fri May 10, 2019 11:04 am

Can you write an issue on github and paste the stack trace there?
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3528
Joined: Wed Jun 04, 2008 11:20 am

Re: Can't enable MH Community Plug-in in Blender

Postby MTKnife » Sat May 11, 2019 1:15 am

Will do when I get a chance--I just posted here to make sure I wasn't doing something stupid and obvious.
MTKnife
 
Posts: 252
Joined: Tue Sep 01, 2015 5:22 am

Re: Can't enable MH Community Plug-in in Blender

Postby MTKnife » Sun May 12, 2019 12:55 am

The next time I loaded it up it enabled just fine. I suspect the registration conflict came from trying to run two different versions of the plug-in during the same session, though I'm not positive I actually did that.
MTKnife
 
Posts: 252
Joined: Tue Sep 01, 2015 5:22 am


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: No registered users and 1 guest