Please post beta 1 bug reports and comments here

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Please post beta 1 bug reports and comments here

Postby joepal » Wed Feb 15, 2017 3:08 pm

As I'm about to announce the availability of 1.1.1-beta1, I'm creating a discussion thread for it.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3137
Joined: Wed Jun 04, 2008 11:20 am

Re: Please post beta 1 bug reports and comments here

Postby wolgade » Wed Feb 15, 2017 4:51 pm

I get an error message when trying to install the ubuntu ppa using synaptic. I'll translate it to English:

E:/var/cache/apt/archives/makehuman-data_1.1.0~git20150707-1_all.deb: Trying to overwrite /usr/share/makehuman/data/eyebrows/eyebrow007.thumb which is also contained in makehuman-bodyparts 1.1.0+20170215143944-1ppa1

I use Ubuntu 16.04 LTS.
wolgade
 
Posts: 722
Joined: Wed Jan 30, 2013 6:50 pm

Re: Please post beta 1 bug reports and comments here

Postby joepal » Wed Feb 15, 2017 4:58 pm

It seems you have another version of MH installed (probably the one delivered by debian or ubuntu), and that it wasn't properly removed by the PPA script.

You should be able to do:

Code: Select all
apt-get remove --purge makehuman-data
apt-get remove --purge makehuman
apt-get install makehuman


Which would likely make things work as expected again.

But it's a good bug report. Obviously the PPA package should take this scenario into account.

I've created an issue for it here http://bugtracker.makehumancommunity.org/issues/1126
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3137
Joined: Wed Jun 04, 2008 11:20 am

Re: Please post beta 1 bug reports and comments here

Postby wolgade » Wed Feb 15, 2017 5:46 pm

joepal wrote:It seems you have another version of MH installed (probably the one delivered by debian or ubuntu), and that it wasn't properly removed by the PPA script.

Don't think so. I use the development version of MH. I was sure makehuman-data was installed as a dependency, but this doesn't seem to be the case. I probably selected it manually. Anyway, it shouldn't be conflicting with makehuman.

This is just a short feedback. I'll have a closer look tomorrow when I've got more time.
wolgade
 
Posts: 722
Joined: Wed Jan 30, 2013 6:50 pm

Re: Please post beta 1 bug reports and comments here

Postby joepal » Wed Feb 15, 2017 8:16 pm

wolgade wrote:
joepal wrote:It seems you have another version of MH installed (probably the one delivered by debian or ubuntu), and that it wasn't properly removed by the PPA script.

Don't think so. I use the development version of MH. I was sure makehuman-data was installed as a dependency, but this doesn't seem to be the case. I probably selected it manually. Anyway, it shouldn't be conflicting with makehuman.

This is just a short feedback. I'll have a closer look tomorrow when I've got more time.


If this is a really old linux installation, it's also possible you have debs from how we divided up the package before. I know I called one part makehuman-data then. But that was a while back.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3137
Joined: Wed Jun 04, 2008 11:20 am

Re: Please post beta 1 bug reports and comments here

Postby Aethelraed_Unraed » Thu Feb 16, 2017 8:52 am

Although the release notes state issue 1054 (the shader problem) is fixed, it's still there for me... :(
I'm using Ubuntu 16.04 x64 with an on-board Intel card with i915 driver.

Oh, and there's someone spamming at the 1.1.1 announcement page http://www.makehumancommunity.org/frontpage/makehuman_111_beta_1.html ;)
User avatar
Aethelraed_Unraed
 
Posts: 35
Joined: Tue Aug 11, 2015 7:55 pm
Location: Netherlands

Re: Please post beta 1 bug reports and comments here

Postby joepal » Thu Feb 16, 2017 10:33 am

Yes, that's correct. That bug is still open.

Thanks, I've removed the spammer.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3137
Joined: Wed Jun 04, 2008 11:20 am

Re: Please post beta 1 bug reports and comments here

Postby wolgade » Thu Feb 16, 2017 12:18 pm

joepal wrote:If this is a really old linux installation,

It's not. I made a clean install of Ubuntu 16.04 back in December after I bought a GTX1070 to speed up rendering. Bleeding edge nvidia drvers and Debian stable seemed to be too much manual work.

But I know what went wrong. To reproduce the error on an absolutely clean installation, I installed Ubuntu 16.04 in a virtual machine and did what your instructions told me. This works without error. If I additionally try to install makehuman-data I'll get the error.
screenshot.png

makehuman-data should be marked as conflicting package.
wolgade
 
Posts: 722
Joined: Wed Jan 30, 2013 6:50 pm

Re: Please post beta 1 bug reports and comments here

Postby joepal » Thu Feb 16, 2017 2:50 pm

Yes. That's the package from ubuntu. But a "Replaces" field will take care of that.

Btw, you only need to check "makehuman" to pull the basic build. It's a meta-package which pulls in the other recommended parts. For "-blendertools", "-docs" and "*-dev" you need to check them explicitly if you want them.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3137
Joined: Wed Jun 04, 2008 11:20 am

Re: Please post beta 1 bug reports and comments here

Postby wolgade » Fri Feb 17, 2017 9:43 am

joepal wrote:Yes. That's the package from ubuntu. But a "Replaces" field will take care of that.

That's what I tried to suggest although I wouldn't have known how to actually do this. I'm not too familliar with creating DEB packages.
Btw, you only need to check "makehuman" to pull the basic build.

That's what I did the second time. The other installed packages you see in the screenshot were installed as dependencies. I guess I know why I at first thought that I might need makehuman-data: As a user of the development version of MH I'm used to having to download the assets separately. This would, of course, be a very bad idea for a package.
wolgade
 
Posts: 722
Joined: Wed Jan 30, 2013 6:50 pm


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: No registered users and 2 guests