Custom Targets Not Saving

If your topic doesn't fit anywhere else, put it here.

Moderator: joepal

Custom Targets Not Saving

Postby Ricardo2020 » Tue Oct 26, 2021 12:23 am

Environment:

Custom built computer inside a microATX cube powered by a Seasonic 850watt PSU, based on Intel LGA1150 Xeon 1246v3 cpu with Noctua NH12 dual push pull fans, 32GB Kingston DDR3, Gigabyte GeForce GTX960 Windforce 2 gpu, Gigabyte B85H workstation board, Samsung EVO 860 500GB ssd, two WB Blue 1TB hdds, LG BVDRW, booting Linux Mint Cinnamon 20.1 Uma. MakeHuman 1.2.0 is in usr/share/makehuman and has files in Home/Documents/Makehuman/v1py3. All permissions are correct. All file structures are correct and accounted for after much testing.

Problem:

I can use any target in the kit and all additions by third parties within the assets repository at MakeHuman Community. All targets work as advertized. However, after creating the model and tweaking it just so, then saving said model, some targets do not save. This is evident upon reopening the model after saving with MakeHuman running or after the program is closed and restarted. Thus, even though the target folders are proper and load up when the program launches, the models do not retain some of these targets.

Prognosis:

I have tested many things across two versions of Make Human, v1.1.1 and v1.2.0 on the same machine described above with both versions exhibiting the same problem even though v1.1.1 was running on Linux Mint Cinnamon 18.2 Sonya. I upgraded both the OS and MakeHuman to study the issue further with hopes of getting it right. However, this minor snang remains. This is a real head scratcher for me and it would be of great help were I to get some assistance with this issue since I am totally dumbfounded as to a solution. I am thanking all who look at this in asvance.
Last edited by Ricardo2020 on Tue Nov 30, 2021 3:52 pm, edited 1 time in total.
Paddle faster. I hear charango music!
User avatar
Ricardo2020
 
Posts: 67
Joined: Sat Apr 18, 2020 4:17 pm
Location: Tennessee

Re: Custom Targets Not Saving

Postby nomorecookies » Tue Nov 30, 2021 6:14 am

remove the spaces from the names, or replace the spaces with a _ or such

Good luck
nomorecookies
 
Posts: 81
Joined: Thu Jul 30, 2020 1:34 pm

Re: Custom Targets Not Saving

Postby Ricardo2020 » Tue Nov 30, 2021 3:53 pm

Many thanks. We have found this solution to be the one which works, the underscore patch...
Paddle faster. I hear charango music!
User avatar
Ricardo2020
 
Posts: 67
Joined: Sat Apr 18, 2020 4:17 pm
Location: Tennessee

Re: Custom Targets Not Saving

Postby loki1950 » Tue Nov 30, 2021 8:14 pm

The reason it was happening is that Linux does not like/work with spaces in the file path at all while Windows does not care so sometimes a Widows user names something with those damn spaces completely oblivious of the rest of the world ;)

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo Ideapad 320-15ABR Win 10/Mint 19
User avatar
loki1950
 
Posts: 1187
Joined: Thu Dec 18, 2014 6:27 pm
Location: Ottawa,Ontario


Return to General discussions about makehuman

Who is online

Users browsing this forum: No registered users and 1 guest