Missing textures

If you have problems understanding something or getting started, ask here

Moderator: joepal

Re: Missing textures

Postby agedperson » Tue Oct 30, 2018 6:48 pm

Thank you all for trying to help with my textures problem.

I have downloaded 6 assets from the Community page of MakeHuman with 3 successes and 3 failures.

I downloaded a different asset by Margaret Toigo (the Turtleneck from Shirts/TShirts) and it showed up successfully.
The Cocktail Dress (by punkduck Gowns/Robes) and Crude Swimsuit (by Joel Palmius Unsorted/Other) were also successful.
The Red Skirt by reizibarrientos (Skirts) showed the dreaded orange and grey stripes which I consider unsuccessful.
The other 2 unsuccessful downloads were the Dress Bodice by Margaret (the prime suspect in this topic) and F Dress 02 (by Mindfront Gowns/Robes).
These 2 latter assets were missing textures which I am now convinced is the fault of my laptop.

Oops. I looked closer at Red Skirt and noticed that the texture in MHmat was the wrong filetype. I changed it and now I see a tartan skirt in MakeHuman. So, 3 and 1/2 out of 6 ain't bad!
Last edited by agedperson on Tue Oct 30, 2018 8:55 pm, edited 1 time in total.
agedperson
 
Posts: 14
Joined: Sat Oct 27, 2018 7:41 pm

Re: Missing textures

Postby agedperson » Tue Oct 30, 2018 7:17 pm

Margaret,

I read your post whilst my mind was trying to make sense of textures, materials, normals, bump maps, etc and all the graphics jargon I've been reading lately and I totally missed who was writing. Senior moments really DO happen!
I am in no way trying to imply that you did anything wrong. In fact, I'm in awe of the assets you have made available. It annoys me that such good work is closed to me.
I have been able to make a couple of assets myself but nothing in your class. I was hoping that I could take advantage of ready-made clothing but my laptop says no.
agedperson
 
Posts: 14
Joined: Sat Oct 27, 2018 7:41 pm

Re: Missing textures

Postby joepal » Tue Oct 30, 2018 9:12 pm

Are you using the asset downloader plugin, or are you downloading manually? The asset downloader tries to do some minor fixing in regards to file paths etc, something that can be easily missed when downloading file links manually.

https://github.com/makehumancommunity/c ... etdownload

The asset downloader will be included in the next version of MH, and is already the recommended way to download assets.

Anyway, the orange stripes thing is a path error, and has nothing to do with the graphics card. It's essentially a big image with the text "did not find texture".
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3531
Joined: Wed Jun 04, 2008 11:20 am

Re: Missing textures

Postby agedperson » Tue Oct 30, 2018 10:54 pm

joepal wrote:Are you using the asset downloader plugin, or are you downloading manually? The asset downloader tries to do some minor fixing in regards to file paths etc, something that can be easily missed when downloading file links manually.

Anyway, the orange stripes thing is a path error, and has nothing to do with the graphics card. It's essentially a big image with the text "did not find texture".


Joel, I tried both plugin and manual and neither outfoxed my laptop. It is determined to reject some assets and allow others. I've worked with Paint Shop Pro, Paint.NET and other graphics programs in the past and it may be that I had to set something or other that I've forgotten and is now giving me a problem.

You probably missed my edit of a previous post where I mentioned that I'd fixed the problem with the orange-and-grey stripes appearing. I wish the other problem was that simple.

Is there by any chance something (like --noshaders) that will specify use ONLY the diffuse texture and ignore everything else?
agedperson
 
Posts: 14
Joined: Sat Oct 27, 2018 7:41 pm

Re: Missing textures

Postby agedperson » Wed Oct 31, 2018 2:47 am

OK Folks. I've figured out how to make the textures visible on my laptop. I enabled the Materials Editor to see if there was anything that didn't look right and saw that both the assets I was having trouble with had Opacity set to 0. I changed it to 1 and saved the files and now I can see the textures. I guess most computers can figure out that it is really nice to be able to see the clothing but my poor old laptop suffers senior moments just like me and falls asleep at the most inappropriate times.
Thank you all who tried to help. No doubt I'll have more questions very soon. Do I have to close out this topic somehow or will it slowly fade away?
agedperson
 
Posts: 14
Joined: Sat Oct 27, 2018 7:41 pm

Re: Missing textures

Postby joepal » Wed Oct 31, 2018 9:09 am

Just leave it. It'll drift towards the bottom of the thread list over time.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3531
Joined: Wed Jun 04, 2008 11:20 am

Re: Missing textures

Postby loki1950 » Wed Oct 31, 2018 3:15 pm

And laugh about those senior moments the number in my forum name is my birth year so I'm sliding into my seventies :lol: Wrote my first code way back in the sixties :ugeek:

Enjoy the Choice :)
my box::HP Envy i5-6400 @2Q70GHzx4 8 Gb ram/1 Tb(Win10 64)/3 Tb Mint 19.2/GTX745 4Gb acer S243HL K222HQL
Q8200/Asus P5QDLX/8 Gb ram/WD 2Tb 2-500 G HD/GF GT640 2Gb Mint 17.3 64 bit Win 10 32 bit acer and Lenovo Ideapad 320-15ABR Win 10/Mint 19
User avatar
loki1950
 
Posts: 925
Joined: Thu Dec 18, 2014 6:27 pm
Location: Ottawa,Ontario

Re: Missing textures

Postby RobBaer » Sat Nov 03, 2018 7:57 pm

agedperson wrote:OK Folks. I've figured out how to make the textures visible on my laptop. I enabled the Materials Editor to see if there was anything that didn't look right and saw that both the assets I was having trouble with had Opacity set to 0. I changed it to 1 and saved the files and now I can see the textures. I guess most computers can figure out that it is really nice to be able to see the clothing but my poor old laptop suffers senior moments just like me and falls asleep at the most inappropriate times.
Thank you all who tried to help. No doubt I'll have more questions very soon. Do I have to close out this topic somehow or will it slowly fade away?

Don't sell yourself or your computer short too fast ...

I think you have discovered something real, but I don't know just what yet. In trying to help you the other night, I downloaded the asset in question on a computer with a newer MH install that I had never enabled the material editor in before and the clothes were missing in the area designated by "hide under clothing". I enabled the material editor to look for what was happening and things fixed themselves. (unlike you I made no tweaks to opacity). I ran out of time to see how reproducible the process was, but in my hands it seemed like something was broken until I enabled the material editor plugin.

I never would have discovered this because most of my computers have the material editor enabled on start up, but I just HAPPENED to use one where it was not. The computer in question is running the "latest and greatest" Windows 10 and has a fairly robust graphics card. You may just have discovered something that is related to the material editor plug-in not being active. I still don't have the evidence to prove it, but there may be something real and undiscovered here.
User avatar
RobBaer
 
Posts: 897
Joined: Sat Jul 13, 2013 3:30 pm
Location: Kirksville, MO USA

Re: Missing textures

Postby Aranuvir » Sat Nov 03, 2018 10:28 pm

@Rob: Is that a problem with old MH or with a recent build?
Aranuvir
 
Posts: 1043
Joined: Sun Oct 12, 2014 2:12 pm

Re: Missing textures

Postby RobBaer » Sun Nov 04, 2018 2:04 am

@Aranuvir
Unfortunately, I don't remember, and my attempts to reproduce the problem by deleting settings and the local copy of the asset asset to start over has failed to reproduce the problem in either py2 release or master to date. [I know what I saw though :) ]
User avatar
RobBaer
 
Posts: 897
Joined: Sat Jul 13, 2013 3:30 pm
Location: Kirksville, MO USA

Previous

Return to Newbies

Who is online

Users browsing this forum: Google [Bot] and 1 guest