Makeclothes export problem

If you have problems understanding something or getting started, ask here

Moderator: joepal

Makeclothes export problem

Postby pratt » Sat Sep 29, 2018 8:36 am

Hi all,
I tried to export a new hair from MakeClothes in Blender, but the export did not work.
The folder has been created, but it remains empty.
Does anyone know where I am wrong?
I joined the Blender file in case someone would like to have a look.
Thanks for your help.
Attachments
cheveux.blend
(46.88 MiB) Downloaded 93 times
pratt
 
Posts: 3
Joined: Mon May 21, 2018 6:33 pm

Re: Makeclothes export problem

Postby MargaretToigo » Sat Sep 29, 2018 8:52 pm

Did you get any error messages from MakeClothes?

Your hair mesh is all triangle faces (519,842 of them, to be exact) and MakeClothes only works on all quad meshes that have no n-gons.

Also, you have two materials and no UV map, and MakeClothes requires a UV map and allows for only one material.

I tried to do the alt=j thing with various angles, but could not get an all-quad result. So, I did a Remesh on it (smooth with and octree depth of 9) and I got an all quad result that looks pretty close to the original but does now have 1,324,776 faces, which is a lot.

MakeClothes works best on low to medium poly meshes. It'll do high poly, but it will take a long time to compile and the results are more likely to be distorted.
Sometimes, even if MakeClothes creates the .mhclo and .obj files, MakeHuman will take a long time -- and can sometimes even crash or return an error -- when it compiles them into .mhpxy and .npz format.

I have a Mac with a 2.9 GHz Intel Core i5 processor and 24 GB of memory and it can take more than an hour to process meshes with over a million faces.

Right now, as I type, your hair mesh has been compiling in the background for almost thirty minutes. I'll report the results when I have some.....
MargaretToigo
 
Posts: 175
Joined: Thu Feb 16, 2017 6:46 pm
Location: Tampa Bay Florida, USA

Re: Makeclothes export problem

Postby Elvaerwyn » Sun Sep 30, 2018 6:11 am

Nice hair! There is a problem with exporting the tri meshes to makehuman that can be resolved by simply changing the mhclo file...in this case I changed it as follows:
from:
max_pole 19
to:
max_pole 38

Tri meshes can work just fine yes. And this mesh had no nygons and was a pure tri mesh.

Its true you need to limit the material to one, and use the uv to create a texture for makehuman.

I unwrapped it very bad, simply hit u twice and rolled with that for proof of concept.

The hair was not associated with the dummy so i did so but used *hair to create the association as this hair fits very close to head. This allowed the mesh to export properly but as per norm with tri mesh would not load in makehuman. At this point i simply edited the mhclo file accordingly and up it loaded to makehuman.

Good luck with your work on this very nice hair mesh.
Elv
Attachments
chev_pratt.zip
hair
(20.78 MiB) Downloaded 86 times
She who knows in repose with prose...
User avatar
Elvaerwyn
 
Posts: 82
Joined: Tue Aug 22, 2017 11:28 pm
Location: Canada

Re: Makeclothes export problem

Postby MargaretToigo » Sun Sep 30, 2018 8:13 am

Okay, I see that Elvaerwyn has found a way to make a tri mesh work -- I always get a MakeClothes error message if there's even one triangle, but I've never played around with the max_pole setting.

Anyhow, I did get it a result on the Remesh, which took almost six hours. I haven't tried loading it onto MakeHuman. These files are huge and the .blend is too big to upload, even compressed.

cheveuxhair.mhclo.zip
(24.26 MiB) Downloaded 92 times


cheveuxhair.obj.zip
(23.49 MiB) Downloaded 88 times


cheveuxhairMaterial.zip
(1013 Bytes) Downloaded 97 times
MargaretToigo
 
Posts: 175
Joined: Thu Feb 16, 2017 6:46 pm
Location: Tampa Bay Florida, USA

Re: Makeclothes export problem

Postby Aranuvir » Sun Sep 30, 2018 11:14 am

I think there are reasons pro and contra tris. In the end, the user should have the choice, whether to use meshes with ngons or not. I consider to add an option in MakeHuman. Though, we probably won't be able to guarantee everything will work flawless...
Aranuvir
 
Posts: 1042
Joined: Sun Oct 12, 2014 2:12 pm

Re: Makeclothes export problem

Postby RobBaer » Sun Sep 30, 2018 11:37 am

MargaretToigo wrote:Okay, I see that Elvaerwyn has found a way to make a tri mesh work -- I always get a MakeClothes error message if there's even one triangle, but I've never played around with the max_pole setting.


I think the rule is ALL tris or ALL quads, so "even 1 triangle" fails because of the "ALL" rule. I have not traced this down in the code though.
User avatar
RobBaer
 
Posts: 894
Joined: Sat Jul 13, 2013 3:30 pm
Location: Kirksville, MO USA

Re: Makeclothes export problem

Postby MargaretToigo » Sun Sep 30, 2018 6:51 pm

Elvaerwyn wrote:Nice hair! There is a problem with exporting the tri meshes to makehuman that can be resolved by simply changing the mhclo file...in this case I changed it as follows:
from:
max_pole 19
to:
max_pole 38

Tri meshes can work just fine yes. And this mesh had no nygons and was a pure tri mesh.

Its true you need to limit the material to one, and use the uv to create a texture for makehuman.

I unwrapped it very bad, simply hit u twice and rolled with that for proof of concept.

The hair was not associated with the dummy so i did so but used *hair to create the association as this hair fits very close to head. This allowed the mesh to export properly but as per norm with tri mesh would not load in makehuman. At this point i simply edited the mhclo file accordingly and up it loaded to makehuman.

Good luck with your work on this very nice hair mesh.
Elv



But how did you get it to work in the first place?

I saw your post and RobBaer's about how a mesh can work if it's ALL tris or ALL quads, but not if it has a combination of both, so I had to try it.

But I got the same results as pratt described in the OP, no error messages, but no result, either.

I was able to export the crude material I made using the "Export Material Only" button, but clicking on MakeClothes didn't even make a .mhmat file, just an empty folder.

Then I downloaded your .zip file and after a bit of straining it compiled in MakeHuman, probably because you'd already edited the .mhclo file.

Screen Shot 2018-09-30 at 2.44.17 PM.png


The thing that's intriguing here is the all-tris mesh and how MakeClothes made "clothes" out of it, which were then readable in MakeHuman with one edit to the max_pole parameter.
MargaretToigo
 
Posts: 175
Joined: Thu Feb 16, 2017 6:46 pm
Location: Tampa Bay Florida, USA

Re: Makeclothes export problem

Postby MargaretToigo » Sun Sep 30, 2018 7:23 pm

Okay, I couldn't get it to work on pratt's hair mesh, but I did just make two very simple and basic all-tris items, which went through MakeClothes just fine, but would not compile in MakeHuman until i changed the max-pole from 8 to 38.

Screen Shot 2018-09-30 at 3.14.02 PM.png
Shirt and Skirt made from all tris -- model has pratt's hair, which was fixed by Elvaerwyn.



Here are the folders and files it made...

shirt_tris.zip
Shirt: mhclo, mhmat, obj, and a png texture
(66.88 KiB) Downloaded 94 times


skirt_tris.zip
Skirt: mhclo, mhmat, obj, and a png texture
(38.65 KiB) Downloaded 92 times


And the Blend, since it's small enough to share.

Skirt-tri-test.blend
(3.93 MiB) Downloaded 91 times
MargaretToigo
 
Posts: 175
Joined: Thu Feb 16, 2017 6:46 pm
Location: Tampa Bay Florida, USA

Re: Makeclothes export problem

Postby MargaretToigo » Sun Sep 30, 2018 8:01 pm

And finally, it took a while (about 20 minutes on a slow Windows machine), but my all-quad version of pratt's hair -- attached to my post above -- did compile in MakeHuman after I changed the max_pole to 38. It did take about six hours to go through MakeClothes, and that was on a pretty fast Mac with lots of memory.

Screen Shot 2018-09-30 at 3.56.20 PM.png
pratt's hair mesh, converted to quads, compiled in MakeHuman. It took about six hours to run through MakeClothes, and then its max_pole was changed from 6 to 38 to make that happen.
MargaretToigo
 
Posts: 175
Joined: Thu Feb 16, 2017 6:46 pm
Location: Tampa Bay Florida, USA


Return to Newbies

Who is online

Users browsing this forum: No registered users and 1 guest