MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby mallow » Mon Mar 02, 2009 1:03 pm

Hi, I`ve been trying to run MakeHuman 1.0 pre-alpha. I`ve downloaded zip archive from this link: http://sourceforge.net/project/showfiles.php?group_id=150931&package_id=211091 (yes, I know it`s i386 architecture only). Is there a way to run this on ubuntu 8.10 64 bit or do I have to wait for 64 bit package (will there be any soon?) ?
When I ran makehuman in terminal, it gave me that I need libpython2.5.so.1.0. I`ve found this workaround: http://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg1284576.html
Now I get this when I try to run makehuman:

Code: Select all
krzysiek@quad:~/linux/pakiety/MakeHuman/makehuman1-0-0_prealpha$ ./makehuman
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "main.py", line 50, in <module>
    import module3d
  File "./mh_core/module3d.py", line 38, in <module>
    import aljabr
  File "./mh_core/aljabr.py", line 25, in <module>
    import math
ImportError: /usr/lib/python2.5/lib-dynload/math.so: wrong ELF class: ELFCLASS64
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 38, in apport_excepthook
    from apport.packaging_impl import impl as packaging
  File "/usr/lib/python2.5/site-packages/apport/__init__.py", line 1, in <module>
    from apport.report import Report
  File "/usr/lib/python2.5/site-packages/apport/report.py", line 14, in <module>
    import subprocess, tempfile, os.path, urllib, re, pwd, grp, os, sys
  File "/usr/lib/python2.5/subprocess.py", line 401, in <module>
    import select
ImportError: /usr/lib/python2.5/lib-dynload/select.so: wrong ELF class: ELFCLASS64

Original exception was:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "main.py", line 50, in <module>
    import module3d
  File "./mh_core/module3d.py", line 38, in <module>
    import aljabr
  File "./mh_core/aljabr.py", line 25, in <module>
    import math
ImportError: /usr/lib/python2.5/lib-dynload/math.so: wrong ELF class: ELFCLASS64
Could not run main Python script
mallow
 
Posts: 1
Joined: Mon Mar 02, 2009 12:49 pm

Re: MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby rtownsend » Fri Mar 06, 2009 4:11 am

I am also interested in MakeHuman on Ubuntu 8.10 64bit. I tried to compile from source, but had problems, and don't really know what I'm doing under Linux. I got animorph and libgen3d to build ok (to be honest, I'm not really sure if they're 64 bit builds), but mhgui failed. The first errors I got were from 'configure':

./configure: line 15768: AX_CHECK_GL: command not found
./configure: line 15777: AX_CHECK_GLU: command not found
./configure: line 15786: AX_CHECK_FREEGLUT: command not found
./configure: line 15815: AX_CHECK_PNG: command not found

then I got, from the make

g++: @GLUT_CFLAGS@: No such file or directory
g++: @FREEGLUT_CFLAGS@: No such file or directory
g++: @PNG_CFLAGS@: No such file or directory
make[2]: *** [CGUtilities.lo] Error 1

Then I started investigating autoconf, etc, and my eyes started to glaze over...

So, I'd be glad to try to help get a 64-bit build going, but would need much guidance.

Robert

System:
CPU: Intel Q9450
Ram: 8GB
GFX: nVidia GeForce 8600 GTS
OS: Ubuntu 8.10 (Intrepid Ibex), 64-bit
Kernel: 2.6.27-11-generic
GNOME: 2.24.1
All updates applied as of March 5, 2009
nVidia Drivers: 177.82
rtownsend
 
Posts: 8
Joined: Fri Mar 06, 2009 12:40 am

Re: MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby ChrisB » Fri Mar 06, 2009 10:06 am

rtownsend wrote:I am also interested in MakeHuman on Ubuntu 8.10 64bit. I tried to compile from source, but had problems, and don't really know what I'm doing under Linux. I got animorph and libgen3d to build ok (to be honest, I'm not really sure if they're 64 bit builds), but mhgui failed.
....
So, I'd be glad to try to help get a 64-bit build going, but would need much guidance.

Robert


It sounds like you're building the wrong deck. The current deck is in the mh_phoenix directory on SVN. You may find the documentation on the Wiki helpful:

http://makehuman.wiki.sourceforge.net/D ... vironment2

This lists the prerequisite, such as SDL and tells you where to get them. A lot of the info currently has a slight Windows bias, but if you are able to write something comparable for 64 bit Ubuntu I'd be happy to integrate that into the Wiki.

Regards,
Chris B.
ChrisB
 
Posts: 17
Joined: Sat Aug 16, 2008 6:51 pm

Re: MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby joepal » Fri Mar 06, 2009 10:11 am

Check

http://www.makehuman.org/forum/viewtopic.php?f=7&t=361

And

http://mh.jwp.se

In order to get a build environment on ubuntu, I have run

Code: Select all
apt-get install build-essential libsdl-console libsdl-perl libsage-dev libsdl1.2-dev freeglut3-dev libglu1-mesa-dev libglut3-dev python2.5-dev


With this, I have successfully compiled on both i386 and x86_64.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3900
Joined: Wed Jun 04, 2008 11:20 am

Re: MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby rtownsend » Sat Mar 07, 2009 2:58 am

OK. Got it running.

Chris B: Thanks for pointing me to the correct tree. After downloading and extracting that, installing the libs mentioned by joepal (thanks Joel - bookmarked your makehuman fan site), installing SCons, running scons in the extracted directory, then running ./makehuman, it came up and ran immediately.

I look forward to watching this develop. What a cool program.

Thanks again,

Robert
rtownsend
 
Posts: 8
Joined: Fri Mar 06, 2009 12:40 am

Re: MakeHuman 1.0 Alpha 1 compile

Postby rtownsend » Sun Apr 12, 2009 8:00 pm

This is an informational note.

When trying to build 1.0 Alpha 1 on Ubuntu 8.10 64-bit, I got an error message when compiling that Python 2.5 was not found. That wasn't true, so I commented out all the checks in SConstruct, and the source compiled ok, but the link failed. It mentioned that -lGL not found (or something like that - I don't remember the exact error message). This was caused by the fact that I upgraded my restricted nVidia graphics drivers - this requires manually installing nvidia-glx-180-dev through Synaptic. After doing so, the program linked and ran fine, even using the original SConstruct file (which now says it finds Python 2.5).

Thought I would document that here, since it was a bit of a time-consuming thing for me, and others might find it helpful.
rtownsend
 
Posts: 8
Joined: Fri Mar 06, 2009 12:40 am

Re: MakeHuman 1.0 Alpha 1 compile

Postby Manuel » Mon Apr 13, 2009 1:28 pm

rtownsend wrote:This is an informational note.


Thought I would document that here, since it was a bit of a time-consuming thing for me, and others might find it helpful.


Thanks
Manuel
 

Re: MakeHuman 1.0 pre-alpha not running on ubuntu 8.10 64bit

Postby Jeremy Ray » Wed Jul 29, 2009 7:09 pm

Help me out before I try installing this - does it do anything? I read that it was missing targets and is non-functional.
Jeremy Ray
 
Posts: 17
Joined: Mon Feb 18, 2008 6:41 am


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: No registered users and 1 guest