Problems with animorph and mhgui

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Problems with animorph and mhgui

Postby tomathjärna » Sun Feb 24, 2008 1:11 pm

I first downloaded the makehuman source package. I executed ./configure, and it complained about not finding animorph or mhgui. I downloaded those two. I compiled animorph and ran 'make install'. But then when i tried to do the same with mhgui, it complained that it still couldn't find animorph. I don't really know what to do now.
I run linux btw.
tomathjärna
 
Posts: 1
Joined: Sun Feb 24, 2008 1:05 pm

Re: Problems with animorph and mhgui

Postby andreas » Tue Feb 26, 2008 3:22 pm

Hello,

Execute 'ldconfig' as root after 'make install' of libanimorph and libmhgui. You need to do that for all software that you compile and install on Linux.

You're the second person asking that question. I should really write this into the INSTALL file of the final.

Thanks for remembering me.

regards
Andreas
andreas
 
Posts: 6
Joined: Tue Feb 19, 2008 7:24 pm

Re: Problems with animorph and mhgui

Postby nphillips » Thu Mar 13, 2008 1:16 am

I'm experiencing this issue, too. Animorph installs fine, and I run ldconfig (as root) after performing the 'make install'. The library files are installed in /usr/local/lib64 (with /usr/local/lib symlinked to that dir).

I've tried setting PKG_CONFIG_PATH=/usr/local/lib and =/usr/local/lib64 (both with and without the trailing slashes...shouldn't make a difference though, iirc).

On a whim, I have also tried running ./configure --with-animorph=/usr/local/lib' but that returned the same error.

I'm running Gentoo amd64, 2.6.23 kernel.

Thanks in advance,
Nate
nphillips
 
Posts: 6
Joined: Thu Mar 13, 2008 1:12 am

Re: Problems with animorph and mhgui

Postby Tommassino » Sun Apr 13, 2008 6:08 pm

Tommassino
 
Posts: 1
Joined: Sun Apr 13, 2008 2:12 pm


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: Bing [Bot] and 1 guest