Page 1 of 1

Blender 4 and Make Clothes 2

PostPosted: Mon Nov 27, 2023 12:43 am
by AlseyWalsey
Does Make Clothes work in Blender 4? When I try to check the box and enable it I get this message

Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender 4.0\4.0\scripts\modules\addon_utils.py", line 364, in enable
mod = importlib.import_module(module_name)
File "C:\Program Files\Blender Foundation\Blender 4.0\4.0\python\lib\importlib\__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 883, in exec_module
File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
File "C:\Users\owner\AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons\makeclothes\__init__.py", line 24, in <module>
from .operators import *
File "C:\Users\owner\AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons\makeclothes\operators\__init__.py", line 6, in <module>
from .extractclothes import MHC_OT_ExtractClothesOperator
File "C:\Users\owner\AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons\makeclothes\operators\extractclothes.py", line 6, in <module>
from ..core_makeclothes_functionality import _loadMeshJson
File "C:\Users\owner\AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons\makeclothes\core_makeclothes_functionality.py", line 11, in <module>
from .utils import checkMakeSkinIntegrity
File "C:\Users\owner\AppData\Roaming\Blender Foundation\Blender\4.0\scripts\addons\makeclothes\utils.py", line 17, in <module>
from io_scene_obj import import_obj
ModuleNotFoundError: No module named 'io_scene_obj'

Re: Blender 4 and Make Clothes 2

PostPosted: Mon Dec 25, 2023 12:20 pm
by green_tomato
I get that error too.
My solution for now is to have an older Blender 3 install for M.H.

Re: Blender 4 and Make Clothes 2

PostPosted: Sun Jan 07, 2024 10:02 am
by yalazur
with the latest version of makeclothe now it worked in blender 4!

Re: Blender 4 and Make Clothes 2

PostPosted: Wed Mar 06, 2024 9:09 am
by Golbrews
I have reinstalled the latest version of Makeecloth and it works well.

Re: Blender 4 and Make Clothes 2

PostPosted: Thu Mar 07, 2024 1:07 pm
by 2Rock
I go to the plug-ins dowload page to get the version of Makeclothes2 that does work with Blender 4 and get a message saying the zip file is not found.

Re: Blender 4 and Make Clothes 2

PostPosted: Thu Mar 07, 2024 2:36 pm
by tomcat
2Rock wrote:I go to the plug-ins dowload page to get the version of Makeclothes2 that does work with Blender 4 and get a message saying the zip file is not found.

MakeClothes 2

community-plugins-makeclothes-master.zip

Re: Blender 4 and Make Clothes 2

PostPosted: Thu Mar 07, 2024 9:32 pm
by punkduck
i did that change yes. In blender they exchanged the old python obj (wavefront) importer/exporter to a c++ one. I guess that one was already there before but as long as the old one was there nobody took notice. At least when you check stackexchange they surprised a few :mrgreen:

I don't work with blender too much atm, but I had to test a few own plugins and since I was aware that we also use a way to import an obj I fixed it same day.

It is not yet part of a new stable 1.2.1 version for windows. I just created one from the master and if all will go well I will replace either the nightly build (last night was in November last year :? ) with this one or will officially put the 1.2.1 to that place. Since we have more windows users, I guess I do that first, after that the PPA for linux. Both is new for me. Today I learnt that the blender-plugins are also generated in a way .. but inside windows.exe it does not make much sense :lol: