Cannot export on Linux Mint

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Cannot export on Linux Mint

Postby Farouk » Sun Jul 28, 2019 10:40 am

Hello,

I have been using MakeHuman on MacOS and Windows and everything worked perfectly. However, I recently installed Linux Mint because I've heard Blender works better with Linux. The problem is that I can't export the models made on MakeHuman in any way, DAE, UV Maps, etc, I always get an error message. I don't want to launch Windows everytime I need to use MakeHuman so I was wondering if someone could help me on the forums.

Here is the error displayed :

Exception during event onFileSelected
Traceback (most recent call last):
File "./core/events3d.py", line 211, in callEvent
method(event)
File "./apps/gui/guiexport.py", line 112, in onFileSelected
exporter.export(gui3d.app.selectedHuman, filename)
File "plugins/9_export_collada/__init__.py", line 132, in export
exportCollada(filename("dae"), cfg)
File "plugins/9_export_collada/mh2collada.py", line 79, in exportCollada
meshes = [obj.mesh.clone(config.scale, filterMaskedVerts=not config.hiddenGeom) for obj in objects]
File "./core/module3d.py", line 160, in clone
self.filterMaskedVerts(other, update=False)
File "./core/module3d.py", line 311, in filterMaskedVerts
inverse_uv_idx[uv_idx] = np.arange(self.texco.shape[0], dtype=np.int32)
ValueError: shape mismatch: value array of shape (21334,) could not be broadcast to indexing result of shape (14517,)
Farouk
 
Posts: 4
Joined: Sun Jul 28, 2019 10:34 am

Re: Cannot export on Linux Mint

Postby Aranuvir » Sun Jul 28, 2019 10:48 am

Get a more recent version of MH or downgrade numpy (guess it should be < 13)
Aranuvir
 
Posts: 1219
Joined: Sun Oct 12, 2014 2:12 pm

Re: Cannot export on Linux Mint

Postby Farouk » Sun Jul 28, 2019 10:52 am

Aranuvir wrote:Get a more recent version of MH or downgrade numpy (guess it should be < 13)


Thank you for your input,
I already have the latest version of MH since I just reinstalled it. However I have no idea what numpy is or how to downgrade it, I'm new to Linux
Farouk
 
Posts: 4
Joined: Sun Jul 28, 2019 10:34 am

Re: Cannot export on Linux Mint

Postby Aranuvir » Sun Jul 28, 2019 11:16 am

in a shell (Bash):

Code: Select all
user@host:~$ sudo apt install python3-numpy python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtopengl python3-opengl git
user@host:~$ mkdir ~/WhereEverYouWantToStoreMakeHuman
user@host:~$ cd ~/WhereEverYouWantToStoreMakeHuman
user@host:~/WhereEverYouWantToStoreMakeHuman$ git clone https://github.com/makehumancommunity/makehuman.git
user@host:~/WhereEverYouWantToStoreMakeHuman$ cd ./makehuman/makehuman
user@host:~/WhereEverYouWantToStoreMakeHuman$/makehuman/makehuman$ ./makehuman


Have fun.

BTW before doing this purge all old code.
Aranuvir
 
Posts: 1219
Joined: Sun Oct 12, 2014 2:12 pm

Re: Cannot export on Linux Mint

Postby Farouk » Sun Jul 28, 2019 12:13 pm

Aranuvir wrote:in a shell (Bash):

Code: Select all
user@host:~$ sudo apt install python3-numpy python3-pyqt5 python3-pyqt5.qtsvg python3-pyqt5.qtopengl python3-opengl git
user@host:~$ mkdir ~/WhereEverYouWantToStoreMakeHuman
user@host:~$ cd ~/WhereEverYouWantToStoreMakeHuman
user@host:~/WhereEverYouWantToStoreMakeHuman$ git clone https://github.com/makehumancommunity/makehuman.git
user@host:~/WhereEverYouWantToStoreMakeHuman$ cd ./makehuman/makehuman
user@host:~/WhereEverYouWantToStoreMakeHuman$/makehuman/makehuman$ ./makehuman


Have fun.

BTW before doing this purge all old code.


thank you a lot, but how do I purge all old code? Does that mean I have to unsinstall MakeHuman?
Farouk
 
Posts: 4
Joined: Sun Jul 28, 2019 10:34 am

Re: Cannot export on Linux Mint

Postby Aranuvir » Sun Jul 28, 2019 12:37 pm

Rethinking it again, it doesn't make a difference. You could also leave the old code, where it is...
Aranuvir
 
Posts: 1219
Joined: Sun Oct 12, 2014 2:12 pm

Re: Cannot export on Linux Mint

Postby joepal » Sun Jul 28, 2019 1:02 pm

Are you sure you're using the latest makehuman binary? It should work on recent mints, although there's a quirk for installing all plugins.

The PPA you should be using is this: https://launchpad.net/~makehuman-offici ... -community, which should work with mint.

If you instead use the 1.1.x PPA (https://launchpad.net/~makehuman-offici ... ehuman-11x), then you'll run into trouble with NumPy.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3870
Joined: Wed Jun 04, 2008 11:20 am

Re: Cannot export on Linux Mint

Postby Farouk » Sun Jul 28, 2019 6:18 pm

joepal wrote:Are you sure you're using the latest makehuman binary? It should work on recent mints, although there's a quirk for installing all plugins.

The PPA you should be using is this: https://launchpad.net/~makehuman-offici ... -community, which should work with mint.

If you instead use the 1.1.x PPA (https://launchpad.net/~makehuman-offici ... ehuman-11x), then you'll run into trouble with NumPy.


Ah, thank you, this worked. I was in 1.1.1. I think it's because I was using the stable version or something. I tried the other method above but I couldn't find the makehuman directory so I don't know if it would have worked. Thanks to all of you!
Farouk
 
Posts: 4
Joined: Sun Jul 28, 2019 10:34 am


Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: Google [Bot] and 2 guests