Rendering problem in aqsis

Tech support and suggestions forum. If you only have a basic question on how to get started, please use the "newbies" forum in the community section.

Moderator: joepal

Rendering problem in aqsis

Postby joepal » Mon Aug 10, 2009 9:13 pm

Rendering problems in Aqsis persists, but have changed.

Now the poor guy looks like he's been in a fight. Or possibly that he stole mommas makeup box and planned to apply protective camouflage painting.

This is from revision 284 (today), build on ubuntu 9.04 64-bit, aqsis 1.2.0:

Image
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3900
Joined: Wed Jun 04, 2008 11:20 am

Re: Rendering problem in aqsis

Postby mflerackers » Mon Aug 10, 2009 9:18 pm

Try removing the older slx files to be sure the shaders are recompiled.
MakeHuman project Developer
mflerackers
 
Posts: 636
Joined: Thu Feb 05, 2009 11:53 am
Location: Kyoto

Re: Rendering problem in aqsis

Postby joepal » Tue Aug 11, 2009 7:43 am

cd makehuman && find . -name "*.slx" -exec "rm" "-f" {} ";"

That didn't help. The end result looks the same.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3900
Joined: Wed Jun 04, 2008 11:20 am

Re: Rendering problem in aqsis

Postby mflerackers » Tue Aug 11, 2009 7:58 am

Any reason why you use aqsis 1.2 instead of 1.4.x?
MakeHuman project Developer
mflerackers
 
Posts: 636
Joined: Thu Feb 05, 2009 11:53 am
Location: Kyoto

Re: Rendering problem in aqsis

Postby Manuel » Tue Aug 11, 2009 9:12 am

It's a bug of Aqsis 1.2.x, fixed in Aqsis 1.4.x.
Aqsis is near 1.6.0, but no .deb available yet. I've talked with Leon Atkinson that tell me the package for linux should be ready very soon (maybe within this week).

Best Regards,

Manuel
Manuel
 

Re: Rendering problem in aqsis

Postby joepal » Tue Aug 11, 2009 9:20 am

mflerackers wrote:Any reason why you use aqsis 1.2 instead of 1.4.x?


It's what comes with Ubuntu 9.04, so it is also likely to be the first renderer your normal linux user will attempt.
Joel Palmius (LinkedIn)
MakeHuman Infrastructure Manager
http://www.palmius.com/joel
joepal
 
Posts: 3900
Joined: Wed Jun 04, 2008 11:20 am

Re: Rendering problem in aqsis

Postby Manuel » Tue Aug 11, 2009 9:39 am

Leon has just sent me the link of the first deb for aqsis 1.5:

https://launchpad.net/~aqsis-team/+archive/ppa

Leon Atkinson wrote:Expand 'aqsis - 1.5.0-2009-08-09-0ubuntu1~ppa~jaunty4 <+sourcepub/695613/+listing-archive-extra>', the debs are within that (including 64-bit).
We're still working on refining the packages so things may change over the next few days, though nothing major.
You'll need 'libaqsis1' and 'aqsis'.
Manuel
 

Re: Rendering problem in aqsis

Postby pistacja » Wed Aug 12, 2009 3:49 pm

I'm also having some problems:
Image
It's the MH alpha 3b, with Aqsis 1.4.2, Windows XP.There where some errors reported while rendering (all in red):
08/12/2009 17:10:29 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 12
08/12/2009 17:10:36 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 19
08/12/2009 17:11:19 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 13
08/12/2009 17:11:31 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 11
08/12/2009 17:21:31 ERROR: Invalid state for RiWorldEnd [BeginEnd]
08/12/2009 17:21:32 ERROR: Invalid state for RiFrameEnd [BeginEnd]
This post was made thanks to Me, Myself and I.
pistacja
 
Posts: 159
Joined: Fri Feb 15, 2008 1:56 pm

Re: Rendering problem in aqsis

Postby Manuel » Wed Aug 12, 2009 5:05 pm

08/12/2009 17:10:29 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 12
08/12/2009 17:10:36 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 19
08/12/2009 17:11:19 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 13
08/12/2009 17:11:31 ERROR: Found a non-manifold vertex in the control hull of object "unnamed" at vertex 11


These can be ignored.

08/12/2009 17:21:31 ERROR: Invalid state for RiWorldEnd [BeginEnd]
08/12/2009 17:21:32 ERROR: Invalid state for RiFrameEnd [BeginEnd]


This is weird. Can you sent me the scena.rib in renderman_output folder?

Regards,

Manuel
Manuel
 

Re: Rendering problem in aqsis

Postby pistacja » Wed Aug 12, 2009 5:26 pm

Sure, I'll just post it here:
Code: Select all
MakeTexture "data/textures/texture.tif" "data/textures/texture.texture" "periodic" "periodic" "box" 1 1 "float bake" 1024
MakeTexture "data/textures/texture_opacity.tif" "data/textures/texture_opacity.texture" "periodic" "periodic" "box" 1 1 "float bake" 1024
MakeTexture "data/textures/texture_ref.tif" "data/textures/texture_ref.texture" "periodic" "periodic" "box" 1 1 "float bake" 1024
MakeTexture "data/textures/texture_mix.tif" "data/textures/texture_mix.texture" "periodic" "periodic" "box" 1 1 "float bake" 1024
FrameBegin 1
Option "searchpath" "shader" "data/shaders/renderman:&"
Option "searchpath" "texture" "data/textures:&"
Hider "hidden" "depthfilter" "midpoint"
Projection "perspective" "fov" 45.000000
Format 512 512 1
PixelFilter "box" 1 1
Clipping 0.1 100
ShadingRate 10
Display "renderman_output/ribFiles/zbuffer.tif" "zfile" "z"
      Rotate -24.9999637248 1 0 0
      Rotate 19.9999716629 0 1 0
      Rotate 7.13799650132e-07 0 0 1
      Translate -9.39302825928 -12.8063840866 25.8071346283
WorldBegin
   AttributeBegin
      ReadArchive "renderman_output/ribFiles/base.obj.rib"
   AttributeEnd
   AttributeBegin
      ReadArchive "renderman_output/ribFiles/hairs.rib"
   AttributeEnd
WorldEnd
FrameEnd
MakeShadow "renderman_output/ribFiles/zbuffer.tif" "renderman_output/ribFiles/zmap.shad"
FrameBegin 17
ScreenWindow -1.333 1.333 -1 1
Option "searchpath" "shader" "data/shaders/aqsis:&"
Option "searchpath" "texture" "data/textures:&"
Display "bake pass" "framebuffer" "rgb"
Projection "perspective" "fov" 25.000000
Format 1280 964 1
Clipping 0.1 100
PixelSamples 1 1
ShadingRate 1
      Translate -0.600000023842 -6.44999980927 14.4999446869
      Rotate -1.5 1 0 0
      Rotate 1434.0 0 1 0
WorldBegin
   LightSource "spotlight" 2 "from" [9.390000 12.800000 -25.800000] "to" [0 0 0] "intensity" 1000  "coneangle" [1.0]
   AttributeBegin
      Color [0.8 0.8 0.8]
      Opacity [1 1 1]
      Translate 0 0 0
      Rotate 0 0 0 1
      Rotate 0 0 1 0
      Rotate 0 1 0 0
      Scale 1 1 1
      Surface "lightmap" "string texturename" "texture.texture" "string outputtexture" "renderman_output/ribFiles/base.obj_map.bake"
      ReadArchive "renderman_output/ribFiles/base.obj.rib"
   AttributeEnd
WorldEnd
FrameEnd
MakeTexture "renderman_output/ribFiles/base.obj_map.bake" "renderman_output/ribFiles/base.obj_map.tx" "periodic" "periodic" "box" 1 1 "float bake" 1024
FrameBegin 18
ScreenWindow -2 2 -1 1
Clipping 0.001 30
Option "searchpath" "shader" "data/shaders/renderman:&"
Option "searchpath" "texture" "data/textures:&"
Display "renderman_output/ribFiles/base.obj_map.tif" "file" "rgb"
Display "+SSS pass" "framebuffer" "rgb"
Format 1024 512 1
PixelSamples 2 2
PixelFilter "gaussian" 1 1
ShadingRate 4
ShadingInterpolation "smooth"
Projection "orthographic"
   WorldBegin
   AttributeBegin
   Color [ 1 1 1 ]   Surface "scatteringtexture" "string texturename" "renderman_output/ribFiles/base.obj_map.tx" "float scattering" [1]
   Translate 0 0 0.02
   Polygon "P" [ -2 -1 0   2 -1 0   2 1 0  -2 1 0 ]"st" [ 0 1  1 1  1 0  0 0  ]
   AttributeEnd
WorldEnd
FrameEnd
MakeTexture "renderman_output/ribFiles/base.obj_map.tif" "renderman_output/ribFiles/base.obj_map.texture" "periodic" "periodic" "box" 1 1
FrameBegin 19
ScreenWindow -1.333 1.333 -1 1
Option "statistics" "endofframe" [1]
Option "searchpath" "shader" "data/shaders/renderman:&"
Option "searchpath" "texture" "data/textures:&"
Projection "perspective" "fov" 25.000000
Format 1280 964 1
Clipping 0.1 100
PixelSamples 2 2
ShadingRate 2
Declare "lighttexture" "string"
Declare "skintexture" "string"
Declare "bumptexture" "string"
Declare "shadowname" "string"
Declare "blur" "float"
Declare "falloff" "float"
Display "Final pass" "framebuffer" "rgb"
Display "+rendering.tif" "file" "rgba"
      Translate -0.600000023842 -6.44999980927 14.4999446869
      Rotate -1.5 1 0 0
      Rotate 1434.0 0 1 0
WorldBegin
   LightSource "ambientlight" 1 "intensity" [.8] "color lightcolor" [1 1 1]
   LightSource "shadowspot" 2 "shadowname" "renderman_output/ribFiles/zmap.shad" "from" [9.390000 12.800000 -25.800000] "to" [0 0 0] "intensity" 1000  "coneangle" [0.785] "blur" [0.005] "float width" [1]
   LightSource "pointlight" 3  "from" [0 12.800000 25.800000] "intensity" 1000
   AttributeBegin
      Color [0.8 0.8 0.8]
      Opacity [1 1 1]
      Translate 0 0 0
      Rotate 0 0 0 1
      Rotate 0 0 1 0
      Rotate 0 1 0 0
      Scale 1 1 1
      Surface "skin" "string mixtexture" "texture_mix.texture" "string opacitytexture" "texture_opacity.texture" "string texturename" "texture.texture" "string speculartexture" "texture_ref.texture" "string ssstexture" "renderman_output/ribFiles/base.obj_map.texture" "float Ks" [.15]
      ReadArchive "renderman_output/ribFiles/base.obj.rib"
   AttributeEnd
   AttributeBegin
      Declare "rootcolor" "color"
      Declare "tipcolor" "color"
      Surface "hair" "rootcolor" [0.109 0.037 0.007] "tipcolor" [0.518 0.325 0.125]
      ReadArchive "renderman_output/ribFiles/hairs.rib"
   AttributeEnd
WorldEnd
FrameEnd
This post was made thanks to Me, Myself and I.
pistacja
 
Posts: 159
Joined: Fri Feb 15, 2008 1:56 pm

Next

Return to Bugs, problems and feature requests

Who is online

Users browsing this forum: No registered users and 1 guest