[SOLVED] ico file does not seem to work

Discussions about user contributed assets. This is a good place to request new assets, as well as requesting support on existing assets that have been downloaded from the user contributions repository.

Moderator: joepal

[SOLVED] ico file does not seem to work

Postby Robitron » Sat Apr 06, 2019 4:16 pm

I've created a pair of men's underwear and would like to add it to the community assets but for some reason, I can't get the ico file to work in my MH geometries file. I was wondering if anyone has the steps proper to use an ico file? I found a tutorial online that showed me how to create the file but I thought it was just a simple matter of putting the ico file in my underwear folder (that would be a very neat invention...) but when I open MH and look at my clothes list, the underwear is there but it still isn't showing the icon that I created for them. :/ Any suggestions?

Here is what I get even with the ico file in the folder.
Missing Icon.PNG
Missing Icon.PNG (4.32 KiB) Viewed 917 times
Last edited by Robitron on Sat Apr 06, 2019 8:22 pm, edited 1 time in total.
Robitron
 
Posts: 110
Joined: Thu Mar 03, 2011 3:42 am

Re: ico file does not seem to work

Postby Aranuvir » Sat Apr 06, 2019 4:44 pm

There's no usage of ico files in MakeHuman. You need to create a thumbnail, which is a renamed 128x128 png file. It must use the same name as the mhclo file: e.g. my_asset.mhclo and my_asset.png --> my_asset.thumb (be aware: the code is probably case sensitive). In 1.2 Alpha you can use the built-in render tool to directly save thumb-files.
Aranuvir
 
Posts: 1029
Joined: Sun Oct 12, 2014 2:12 pm

Re: ico file does not seem to work

Postby Robitron » Sat Apr 06, 2019 5:14 pm

Okay so I exported it from gimp as a png file but can't figure out how to give it the .thumb extension.
Robitron
 
Posts: 110
Joined: Thu Mar 03, 2011 3:42 am

Re: ico file does not seem to work

Postby Aranuvir » Sat Apr 06, 2019 5:26 pm

Aranuvir wrote:There's no usage of ico files in MakeHuman. You need to create a thumbnail, which is a renamed 128x128 png file. It must use the same name as the mhclo file: e.g. my_asset.mhclo and my_asset.png --> my_asset.thumb (be aware: the code is probably case sensitive). In 1.2 Alpha you can use the built-in render tool to directly save thumb-files.
Aranuvir
 
Posts: 1029
Joined: Sun Oct 12, 2014 2:12 pm

Re: ico file does not seem to work

Postby Robitron » Sat Apr 06, 2019 5:45 pm

Okay, I understood your post...for the most part and had renamed it appropriately, had the size set to 128x128 and exported it as a png but it still didn't work so the part of your post (that you forgot to shout at me) was "my_asset.png --> my_asset.thumb." So I thought that meant that I needed to change it to a thumb file!

So, (without the shouting please) why is it that when I renamed it, set the size to 128x128 and exported it as a png, it still doesn't work?

And I haven't even considered using the MH renderer because I want to use a custom pose and it's a good thing I didn't because Heaven forbid I have a problem with it and have to ask questions in here to be shouted down.

Thank you for you patience and respect.
Robitron
 
Posts: 110
Joined: Thu Mar 03, 2011 3:42 am

Re: ico file does not seem to work

Postby Aranuvir » Sat Apr 06, 2019 6:03 pm

Sorry, but It wasn't my intention to shout, I just wanted to emphasize the important parts of my explanation. :)
As I said, the thumbnail must have the same name as the mhclo-file and you must mind the spelling. my_asset.mhclo and My_asset.thumb will not work. I'm not sure about the situation on Windows, but it definitely won't work on Unix-like systems. File.thumb, fILE.thumb FiLe.thumb and file.thumb are all different files...
Aranuvir
 
Posts: 1029
Joined: Sun Oct 12, 2014 2:12 pm

Re: ico file does not seem to work

Postby Robitron » Sat Apr 06, 2019 6:17 pm

Ah, I see what you're saying and appreciate the apology. I made sure that the spelling and capitalization were the same but still can't get the right results. So I'm still perplexed about this.
Robitron
 
Posts: 110
Joined: Thu Mar 03, 2011 3:42 am

Re: ico file does not seem to work

Postby Aranuvir » Sat Apr 06, 2019 6:36 pm

A) Just to make sure: You triggered tab reloading, e.g. by moving to another tab or restarting MH?

B) If this does not help, can you check the log tab for errors?

C) If there are no errors, can you provide the files for further inspection?
Aranuvir
 
Posts: 1029
Joined: Sun Oct 12, 2014 2:12 pm

Re: ico file does not seem to work

Postby Robitron » Sat Apr 06, 2019 6:39 pm

A) Yes, I started MH
B) There are no errors
C) Where should I upload the files for sharing?
Robitron
 
Posts: 110
Joined: Thu Mar 03, 2011 3:42 am

Re: ico file does not seem to work

Postby Aranuvir » Sat Apr 06, 2019 6:43 pm

It should be possible to upload zip-files as attachment...
Aranuvir
 
Posts: 1029
Joined: Sun Oct 12, 2014 2:12 pm

Next

Return to Assets, asset repositories and asset downloader

Who is online

Users browsing this forum: No registered users and 1 guest